1.Написать программу вывода чисел от a до b( a и b вводит пользователь) с шагом в 1.
2.Вывести их произведение и сумму.
c++
Ответы на вопрос
Ответил CzarAlex
0
// TDM-GCC 4.9.2
#include <iostream>
#include <cstdlib>
int main(int argc, char *argv[])
{
system("chcp 1251 >nul");
setlocale(LC_ALL, "Russian");
srand(time(NULL));
int st, nd, n1 = 0;
double n2 = 1;
printf("Введите начальное и конечное число: ");
scanf("%d%d", &st,&nd);
printf("Промежуток: ");
for(int i = st; i < nd+1; i++)
printf("%d ",i);
for(int i = st; i < nd+1; i++)
n1 += i, n2 *= i;
std::cout << "nСумма: " << n1;
std::cout << "nПроизведение: " << n2;
return EXIT_SUCCESS;
}
#include <iostream>
#include <cstdlib>
int main(int argc, char *argv[])
{
system("chcp 1251 >nul");
setlocale(LC_ALL, "Russian");
srand(time(NULL));
int st, nd, n1 = 0;
double n2 = 1;
printf("Введите начальное и конечное число: ");
scanf("%d%d", &st,&nd);
printf("Промежуток: ");
for(int i = st; i < nd+1; i++)
printf("%d ",i);
for(int i = st; i < nd+1; i++)
n1 += i, n2 *= i;
std::cout << "nСумма: " << n1;
std::cout << "nПроизведение: " << n2;
return EXIT_SUCCESS;
}
Ответил CzarAlex
0
TDM-GCC 4.9.2
Новые вопросы