Информатика, вопрос задал NikaChernika , 8 лет назад

1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры.

2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры.

3. Написать программу, вычисляющую среднее арифметическое чисел, принадлежащих диапазону [–5; 5], среди пяти, вводимых с клавиатуры

Ответы на вопрос

Ответил dant02
0
Program z1;
var a,i,sum:integer;
Begin
sum:=0;
for i:=1 to 5 do
begin;
read(a);
if (a<0) and (a mod 5=0) then
sum:=sum+a;
end;
writeln(sum);
End.

Program z2;
var a,p,i:integer;
Begin
p:=1;
for  i:= 1 to 5 do
begin;
read(a);
if (a mod 10=2) or (a mod 10=4) then
p:=p*a;
end;
writeln(p);
End.







Новые вопросы