Информатика, вопрос задал clarkgon9 , 2 года назад

1. Написать программу вычисления сумм всех положительных элементов массива вводимых с клавиатуры.
2. Написать программу вычисления кол-ва нечетных чисел массива.
3. Написать программу поиска наименьшего элемента массива

Ответы на вопрос

Ответил ceneba1293
1

Ответ:

const

 n = 25;

 

var

 a: array[1..n] of integer;

 k0, k, i, s: integer;

 p: real;

 

begin

 s := 0;

 p := 1;

 k := 0;

 k0 := 0;

 for i := 1 to n do

 begin

   a[i] := -n div 2 + random(n);

   Write(a[i]:4);

   if a[i] = 0 then

     inc(k0);

   if a[i] > 0 then

     s := s + a[i];

   if a[i] < 0 then

   begin

     p := p * a[i];

     inc(k);

   end;

 end;

 WriteLn;

 Writeln('Сумма: ', s);

 Writeln('Количество 0: ', k0);

 if k <> 0 then

   Writeln('Произведение: ', p)

 else

   Writeln('Нет таких чисел. ')

end.

Объяснение:


clarkgon9: Это 1?
ceneba1293: да
Новые вопросы