Информатика, вопрос задал dgon99 , 9 лет назад

1. Написать программу вычисления площади кольца, где исходными
данными являются радиусы кольца и отверстия. Предусмотреть в
программе проверку правильности исходных данных (радиус отверстия не
может быть больше радиуса кольца). Сделать на паскале и можно в документе прикрепить

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var r1:=abs(ReadReal('Наружный радиус кольца'));
  var r2:=abs(ReadReal('Внутренний радиус кольца'));
  if (r1*r2>0) and (r1>r2) then
    Writeln('Площадь кольца ',pi*(sqr(r1)-sqr(r2)))
  else Writeln('Неверные данные')
end.

Тестовое решение:
Наружный радиус кольца 25
Внутренний радиус кольца 21.8
Площадь кольца 470.484915801607
Ответил dgon99
0
Спасибо :)
Ответил Аноним
0
Пожалуйста
Новые вопросы