Информатика, вопрос задал alexprokhoro21ff , 8 лет назад

1) Написать программу в паскале, "проверить, являются ли цифры введенного трехзначного числа возрастающей последовательностью"
2) Написать программу в паскале, "по введенным координатам точки (х,у) определить в какую четверть попадает эта точка"

Ответы на вопрос

Ответил AnonimusPro
0
1)
Program n1;
var n:integer;
begin
write('Введите 3-х значное число: ');
readln(n);
if ((n div 100 < n div 10 mod 10) and (n div 10 mod 10 < n mod 10)) then
writeln('true')
else writeln('false');
end.
2)
Program n2;
var x,y: real;
begin
readln(x,y);
if(x=0) and (y=0) then writeln('точка в начале координат')
else if(x>0)and(y>0) then writeln('I четверть')
else if(x<0)and(y>0) then writeln('II четверть')
else if(x<0)and(y<0) then writeln('III четверть')
else if(x>0)and(y<0) then writeln('IV четверть')
else if(x=0)and(y<>0) then writeln('точка на оси OY')
else if(x<>0)and(y=0) then writeln('точка на оси OX');
end.
Новые вопросы