Информатика, вопрос задал tkachenkovaannp2iby4 , 7 лет назад

1. Написать программу, которая запрашивает массив размерности N и выводит на

экран сам массив, а также наибольший и наименьший элементы массива. Протестировать программу на массивах размерностью 5 элементов.

2. Написать программу, которая запрашивает массив из N элементов, а затем делит

все элементы массива на минимальный элемент. Протестировать программу на масси-

вах размерностью 5 элементов.

3. Написать программу, которая запрашивает массив из N элементов и увеличивает все элементы массива на максимальный элемент. Протестировать программу на массивах размерностью 8 элементов.

Ответы на вопрос

Ответил raf1O5
0

1.                                        

program raf105;

const

 n = 5;

var

 a: array[1..n] of integer;

 x,max,min,i: integer;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

max:= a[1];

min:= a[1];

for i:=1 to n do

begin

 if max < a[i]

   then max:= a[i];

 if min > a[i]

   then min:= a[i];

end;

writeln;

write('Массив: ');

for i:=1 to n do

 write(a[i],' ');

writeln;

writeln('Наибольший элемент: ',max);

writeln('Наименьший элемент: ',min);

end.

2.                                        

program raf105;

const

 n = 5;

var

 a: array[1..n] of real;

 x,i: integer;

 min: real;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

writeln;

write('Исходный массив: ');

for i:=1 to n do

 write(a[i],' ');

min:= a[1];

for i:=1 to n do

 if min > a[i]

   then min:= a[i];

for i:=1 to n do

 a[i]:= a[i]/min;

writeln;

write('Изменённый массив: ');

for i:=1 to n do

 write(a[i],' ');

end.

3.                                        

program raf105;

const

 n = 8;

var

 a: array[1..n] of integer;

 x,i,max: integer;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

writeln;

write('Исходный массив: ');

for i:=1 to n do

 write(a[i],' ');

max:= a[1];

for i:=1 to n do

 if max < a[i]

   then max:= a[i];

for i:=1 to n do

 a[i]:= a[i]+max;

writeln;

write('Изменённый массив: ');

for i:=1 to n do

 write(a[i],' ');

end.

                                         

PascalABC 3.4.2

Новые вопросы