Информатика, вопрос задал sashatuan25 , 2 года назад

1. Написать программу, которая задаёт последовательность из 10 случайных чисел не превышающих 20.
2. Написать программу для нахождения суммы элементов в массиве, удовлетворяющих условию: «больше 20, но не меньше 50». Если сумма нечётная, то вывести на экран знак "+" иначе "-".

Ответы на вопрос

Ответил oooooooooooooooo10
2

Ответ:

a = int(input())

b = sorted(list(map(int, input().split())))

c = int(input())

d = list(map(int, input().split()))

answers = list()

for x in d:

   i = -1

   R = a

   while R - i > 1:

       c = (R + i) // 2

       if b[c] <= x:

           i = c

       else:

           R = c

   answers.append(R)

print(*answers)

Объяснение:


sashatuan25: Прежде - большое спасибо. Это ко 2 ответ, так ведь? И что это за язык программирования?
Новые вопросы