1) Написать программу, которая вычисляет сумму первых n целых положительных чисел. Количество суммируемых чисел должно вводиться во время работы программы. (Использовать цикл While)
Ответы на вопрос
Ответил MagicSpace
0
var
n, a, sum, i: longint;
begin
readln(n);
sum := 0;
i := 1;
while (i <= n) do beign
read(a);
sum := sum + a;
inc(i);
end;
writeln(sum);
end.
n, a, sum, i: longint;
begin
readln(n);
sum := 0;
i := 1;
while (i <= n) do beign
read(a);
sum := sum + a;
inc(i);
end;
writeln(sum);
end.
Ответил elenaklon
0
var i,s,n:Integer;
begin
ReadLn(n);
while i<n do
begin
i:=i+1;
s:=s+i
end;
WriteLn(s)
end.
begin
ReadLn(n);
while i<n do
begin
i:=i+1;
s:=s+i
end;
WriteLn(s)
end.
Новые вопросы
Русский язык,
2 года назад
Математика,
8 лет назад
Биология,
8 лет назад
Математика,
9 лет назад
Математика,
9 лет назад