1). Написать программу, которая вычисляет частное от деления
ДВУХ чисел. Программа должна проверять правильность
введенных пользователем данных и, если они неверные
(делитель равен нулю), выдавать сообщение об ошибке.
Вычисление частного.
Введите в одной строке делимое и делитель,
затем нажмите
-> 12 O
Вы ошиблись. Делитель не должен быть
равен нулю.
На С.пожалуйста
givemefuqinanswer:
Простой С или плюсы?
Ответы на вопрос
Ответил givemefuqinanswer
1
Відповідь:
#include <stdio.h>
int main()
{
int num1, num2;
scanf("%d%d", &num1, &num2);
if (num2==0){
printf("Вы ошиблись. Делитель не должен быть равен нулю.\n");
} else {
double result = (double)num1/(double)num2;
printf("%f\n", result);
};
return 0;
}
Приложения:

Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Українська мова,
2 года назад
Английский язык,
2 года назад
Математика,
8 лет назад