1) написать программу, которая считает сумму, в pascal abc 1+1/2+1/3+...+1/28, используя цикл while
2) написать программу, которая считает сумму, в pascal abc 1+1/2+2+1/3+3+1/4...+1/10+10, используя цикл while
3) написать программу, которая считает сумму, в pascal abc 1-2+3-4+...-28, используя цикл while
решите хотя бы две, пожалуйста
Ответы на вопрос
Ответил Arkan3ooo
0
1)
var i,a:integer;
c:real;
begin
i:=1;
c:=0;
while i<=28 do begin
c:=c+1/i;
i:=i+1;
end;
writeln(c);
end.
2)
var i,a:integer;
c:real;
begin
i:=2;
c:=1;
while i<=10 do begin
c:=c+1/i+i;
i:=i+1;
end;
writeln(c);
end.
3)
var c,i:integer;
begin
c:=0;
i:=1;
while i<=28 do begin
if i mod 2 = 1 then c:=c+i else c:=c-i;
i:=i+1;
end;
writeln(c);
end.
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Алгебра,
7 лет назад
Математика,
7 лет назад
Математика,
9 лет назад