1 написать программу которая проверяет на кратность 5 произведение цифр двузначного числа вводимого с клавиатуры в ответе написать ДА или НЕТ.
2 написать программу которая удваивает наибольшую цифру двузначного целого числа результат на экран.
3 написать программу которая утраивает четные цифры двузначного числа результат на экран.
Ответы на вопрос
Ответил petyaGavrikov
0
1.
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1*a2 mod 5 = 0
then writeln('Да') else writeln('Нет');
end.
Пример:
a = 52
Да
2.
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1>a2
then writeln('2*',a1,' = ',2*a1) else writeln('2*',a2,' = ',2*a2);
end.
Пример:
a = 93
2*9 = 18
3.
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1 mod 2 = 0 then writeln('3*',a1,' = ',3*a1);
if a2 mod 2 = 0 then writeln('3*',a2,' = ',3*a2);
end.
Пример:
a = 45
3*4 = 12
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1*a2 mod 5 = 0
then writeln('Да') else writeln('Нет');
end.
Пример:
a = 52
Да
2.
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1>a2
then writeln('2*',a1,' = ',2*a1) else writeln('2*',a2,' = ',2*a2);
end.
Пример:
a = 93
2*9 = 18
3.
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1 mod 2 = 0 then writeln('3*',a1,' = ',3*a1);
if a2 mod 2 = 0 then writeln('3*',a2,' = ',3*a2);
end.
Пример:
a = 45
3*4 = 12
Новые вопросы
Математика,
2 года назад
Обществознание,
2 года назад
Биология,
8 лет назад
Алгебра,
8 лет назад
География,
9 лет назад