Информатика, вопрос задал Nttkz , 2 года назад

1)Написать программу, которая посчитает сколько в массиве элементов чей номер кратен трём(каждый третий элемент)

2) Ване на дом дали задание, написать такую программу: с клавиатуры вводятся два каких-то числа k и m, потом считается и выводится среднее арифметического отрезка чисел от k до m, которые кратны 3.

ПОМОГИТЕ НАПИСАТЬ НА ПИТОНЕ ОЧЕНЬ СРОЧНО

Ответы на вопрос

Ответил SamiraSayf07
1

Ответ:

Объяснение:

Первая программа:

a = list(map(int,input().split()))

p = 0

for i in range (0,len(a)):

   if i % 3 == 0:

       p+= 1

print(p)

(Вводим список, прогоняем его по циклу for по всем элементам. Нумерация элементов идет с 0, если номер цикла при делении на 3 имеет остаток 0 (нацело делится), то в переменную p прибавляем 1. После цикла принтуем переменную p, количество элементов с индексом, кратным 3)

Вторая программа:

a,b = map(int,input().split())

summ = 0

p = 0

for i in range(a,b+1):

   if i % 3 == 0:

       summ += i

       p += 1

print(summ/p)

(Записываем 2 числа в одну строку, задаем переменную summ(сумма элементов, кратных 3) значение 0 и переменной p(количество таких чисел) значение 0. Прогоняем все числа от a до b(с шагом 1) по циклу for. Если число в диапазоне делится на 3 нацело, то к переменной summ прибавляем число, а к переменной p - единицу. После цикла выводим ср.арифметическое(сумму всех чисел делим на их количество)

Если что-то непонятно - спрашивайте.


Nttkz: СПАСИБО ОГРОМНОЕ!!
Храни тебя господь!!
Nttkz: Почему ни одна программа ничего не выводит?
SamiraSayf07: Не знаю, вроде команда print присутствует...
SamiraSayf07: Я перед публикацией ответа на Thonny прогоняла несколько тестов, вроде все правильно выводил...
Nttkz: Да, все работает, спасибо ещё раз!)
Новые вопросы