1.Написать программу, которая определяет наибольшее отрицательное целое число в массиве из 10 элементов.
Значения элементов массива вводятся пользователем.
2.Написать программу, которая определяет наибольшее по модулю число в массиве из 10 введенных пользователем чисел.
Ответы на вопрос
Ответил asoiiu
0
1.
var
mas: array[0..10] of Integer ;
i,min,j: Integer;
begin
min:=0;
writeln('Введите числа:');
for i := 1 to 10 do begin
ReadLn(mas[i]);
if (mas[i] <0)
then j:=mas[i];
if j then min:=j;
end;
WriteLn('Минимальное отрицательное число:',min);
end.
2.
var
mas: array [0..10] of Integer;
i, max, j: Integer;
begin
writeln('Введите числа:');
for i := 1 to 10 do
begin
ReadLn(mas[i]);
if abs(mas[i - 1]) < abs(mas[i]) then
max := mas[i] ;
end;
WriteLn('Наибольшее по модулю число:', max);
end.
var
mas: array[0..10] of Integer ;
i,min,j: Integer;
begin
min:=0;
writeln('Введите числа:');
for i := 1 to 10 do begin
ReadLn(mas[i]);
if (mas[i] <0)
then j:=mas[i];
if j then min:=j;
end;
WriteLn('Минимальное отрицательное число:',min);
end.
2.
var
mas: array [0..10] of Integer;
i, max, j: Integer;
begin
writeln('Введите числа:');
for i := 1 to 10 do
begin
ReadLn(mas[i]);
if abs(mas[i - 1]) < abs(mas[i]) then
max := mas[i] ;
end;
WriteLn('Наибольшее по модулю число:', max);
end.
Новые вопросы