Информатика, вопрос задал danilpolishchuk2019 , 1 год назад

1. Написать программу, которая формирует случайным образом
массив из 15 целых чисел, лежащих в диапазоне от 0 до 5,
после чего на экран выводятся элементы массива с номерами
их индексов.
2. Написать программу, которая формирует массив из 20
случайных чисел целых чисел и выводит на экран элементы,
кратные числу 4.
3. Написать программу, которая из случайно сформированного
одномерного массива размерности 10 выводит только те
элементы, значения которых принадлежат отрезку [-6; 30].
Для заполнения массива использованы случайные числа от -
10 до 50.

Ответы на вопрос

Ответил BobbyFresnel
1

// PascalABC.NET

begin

 Writeln('=1=');

 var a := ArrRandom(15, 0, 5);

 a.Select((v, i) -> (i + 1, v)).Println;

 Writeln('=2=');

 a := ArrRandom(20, -99, 99);

 a.Println.Where(p -> p mod 4 = 0).Println;

 Writeln('=3=');

 a := ArrRandom(10, -10, 50);

 a.Println.Where(p -> p in Range(-6, 30)).Print

end.

Приложения:
Новые вопросы