1)Дан одномерный массив. Положительные элементы уменьшить в два раза, отрицательные заменить их индексами.
2)Дан одномерный массив. Найти произведение элементов массива.
паскаль
написать программу
если можно блок схему
Ответы на вопрос
Ответил pacixor
0
//Pascal
//Массивы размеров 10 элементов заполняются случайными числами от -10 до 10
//1
var
A: array[1..10] of real;
i: byte;
begin
randomize;
writeln('Исходный массив.');
for i := 1 to 10 do
begin
A[i] := random(21)-10;
write(A[i]:5);
end;
writeln;
writeln('Измененный массив.');
for i := 1 to 10 do
begin
if A[i] > 0 then A[i] := A[i] / 2
else A[i] := i;
write(A[i]:5);
end;
writeln;
end.
//2
var
A: array[1..10] of integer;
i: byte;
mult: longint;
begin
mult := 1;
randomize;
writeln('Исходный массив.');
for i := 1 to 10 do
begin
A[i] := random(21)-10;
mult := mult * A[i];
write(A[i]:5);
end;
writeln;
writeln('Произведение элементов массива = ', mult);
end.
//Массивы размеров 10 элементов заполняются случайными числами от -10 до 10
//1
var
A: array[1..10] of real;
i: byte;
begin
randomize;
writeln('Исходный массив.');
for i := 1 to 10 do
begin
A[i] := random(21)-10;
write(A[i]:5);
end;
writeln;
writeln('Измененный массив.');
for i := 1 to 10 do
begin
if A[i] > 0 then A[i] := A[i] / 2
else A[i] := i;
write(A[i]:5);
end;
writeln;
end.
//2
var
A: array[1..10] of integer;
i: byte;
mult: longint;
begin
mult := 1;
randomize;
writeln('Исходный массив.');
for i := 1 to 10 do
begin
A[i] := random(21)-10;
mult := mult * A[i];
write(A[i]:5);
end;
writeln;
writeln('Произведение элементов массива = ', mult);
end.
Новые вопросы
Обществознание,
2 года назад
Немецкий язык,
2 года назад
Математика,
8 лет назад
Математика,
9 лет назад