Информатика, вопрос задал KRblMRUS , 2 года назад

1. Дан одномерный массив A[1..10]. Написать программу, которая найдет номер наименьшего элемента в массиве, заданного датчиком случайных чисел на интервале [-12, 18].

Ответы на вопрос

Ответил petyaGavrikov
1

Ответ:

const n=10;

var a:array[1..n] of integer;

i,min,imin:integer;

begin

Randomize;

writeln('Массив A:');

for i:=1 to n do

begin

a[i]:=random(31)-12;

write(a[i]:4);

end;

writeln;

min:=a[1]; imin:=1;

for i:=2 to n do

if a[i]<min then begin min:=a[i]; imin:=i; end;

writeln('min = ',min,' imin = ',imin);

end.

Пример:

Массив A:

-11  -5  -4   2  14  18  -4  -7 -12   5

min = -12 imin = 9

Новые вопросы