1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.
2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.
Ответы на вопрос
Ответил PopCop312
0
var a:array[1..50000] of integer;
n,i,p:integer;
sr:real;
begin
readln(n);
p:=1;
for i:=1 to n do begin
read(a[i]);
p*=a[i];
end;
sr:=(a[2]+a[n-1])/2;
writeln('Среднее ар. - ',sr:2:1,' произведение - ',p);
end.
n,i,p:integer;
sr:real;
begin
readln(n);
p:=1;
for i:=1 to n do begin
read(a[i]);
p*=a[i];
end;
sr:=(a[2]+a[n-1])/2;
writeln('Среднее ар. - ',sr:2:1,' произведение - ',p);
end.
Новые вопросы
Қазақ тiлi,
2 года назад
Математика,
10 лет назад
Математика,
10 лет назад
Физика,
10 лет назад
Математика,
10 лет назад