1). Дан массив из n чисел (n четное). Написать программу миняющую местами элементы с четными и нечетными номерами
2). Дан массив из n чисел. Написать программу циклически сдвигающую элементы массива на 1 позицию вправо ( 7,8,9,10,15,14 ; 14,7,8,9,10,15)
Ответы на вопрос
Ответил zavgorodny2013
0
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
const
nmax = 20;
var
A : array [1..nmax] of integer;
i, n, temp : integer;
begin
Randomize;
Repeat
Write('Размер массива: ');
Readln(n);
until n in [1..nmax];
Writeln('Исходный массив: ');
for i := 1 to n do
begin
A[i] := random(30);
Write(A[i], ' ');
end;
Writeln;
Writeln('Массив после изменений: ');
temp := a[n];
for i := n downto 2 do a[i] := a[i - 1];
a[1] := temp;
for i := 1 to n do Write(A[i], ' ');
end.
Новые вопросы