Информатика, вопрос задал koskinen1lena , 8 лет назад

1
5 - 9 классы Информатика 5 баллов


Напишите программу, которая в последовательности натуральных чисел определяет количество чисел ,кратных 3 и оканчивающихся на 2.Программа получает на вход натуральные числа, количество введенных чисел неизвестно последовательность чисел заканчивается числом 0.Кол-во чисел не привыкает 100.Введеные числа не привышают 300

Ответы на вопрос

Ответил AnonimusPro
0
Program n1;
var k,a: integer;
begin
readln(a);
k:=0;
while a<>0 do
begin
if (a mod 10=2) and (a mod 3=0)
then k:=k+1;
readln(a);
end;
write(k);
end.
Новые вопросы